Back to overview
Degraded

Swap Program Events Parsing

Sep 16 at 08:19pm GMT+8
Affected services
Swap API
Price API V2
Swap API
Price API V2

Resolved
Sep 16 at 09:09pm GMT+8

This issue has been fixed, please check. Apologies.

Please reach out to us if you have any questions.

Created
Sep 16 at 08:19pm GMT+8

There has been a bad deployment that affects swap events parsing.

It will affect the swap events you see in the transaction, showing wrong mints or affects your parsing mechanism for other usages.

The transaction should execute as expected, only the swap event parsing has issues.

You can check the source/destination token accounts in the instruction to verify what mints were swapped.

We are working on a fix and will update.